aboutsummaryrefslogtreecommitdiff
path: root/node_modules/lodash/flake.nix
diff options
context:
space:
mode:
authorJoel Kronqvist <work.joelkronqvist@pm.me>2022-03-11 20:46:06 +0200
committerJoel Kronqvist <work.joelkronqvist@pm.me>2022-03-11 20:46:06 +0200
commit080c5819d87b933816d724a83f3bf4f1686770a7 (patch)
tree4a2ccc68b27edf7d4cbc586c932cc7542b655e19 /node_modules/lodash/flake.nix
parent5ac7049a9d30733165cc212dee308163c2a14644 (diff)
parentd003b82235a9329f912522a2f70aa950dfce4998 (diff)
downloadLYLLRuoka-080c5819d87b933816d724a83f3bf4f1686770a7.tar.gz
LYLLRuoka-080c5819d87b933816d724a83f3bf4f1686770a7.zip
Merge branch 'master' of https://github.com/JoelHMikael/FoodJS
Updating remote changes
Diffstat (limited to 'node_modules/lodash/flake.nix')
-rw-r--r--node_modules/lodash/flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/node_modules/lodash/flake.nix b/node_modules/lodash/flake.nix
new file mode 100644
index 0000000..15a451c
--- /dev/null
+++ b/node_modules/lodash/flake.nix
@@ -0,0 +1,20 @@
+{
+ inputs = {
+ utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, utils }:
+ utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = nixpkgs.legacyPackages."${system}";
+ in rec {
+ devShell = pkgs.mkShell {
+ nativeBuildInputs = with pkgs; [
+ yarn
+ nodejs-14_x
+ nodePackages.typescript-language-server
+ nodePackages.eslint
+ ];
+ };
+ });
+}