aboutsummaryrefslogtreecommitdiff
path: root/node_modules/lodash/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'node_modules/lodash/flake.nix')
-rw-r--r--node_modules/lodash/flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/node_modules/lodash/flake.nix b/node_modules/lodash/flake.nix
new file mode 100644
index 0000000..15a451c
--- /dev/null
+++ b/node_modules/lodash/flake.nix
@@ -0,0 +1,20 @@
+{
+ inputs = {
+ utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, utils }:
+ utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = nixpkgs.legacyPackages."${system}";
+ in rec {
+ devShell = pkgs.mkShell {
+ nativeBuildInputs = with pkgs; [
+ yarn
+ nodejs-14_x
+ nodePackages.typescript-language-server
+ nodePackages.eslint
+ ];
+ };
+ });
+}